The Register's Annual Great Bicycle Ride Across Iowa

registration issues

I have been trying to register since last night with no luck. I already have a username and password from numerous years past and it doesn’t recognize it and then I try to create a new one and it says I need to be logged in to do that, WTH?? anyone register since last night?

10 Replies

Profile photo of James
thangamalang, January 27, 2013 at 11:28 am

pj – Your username and password for this forum should not be the same as the registration login username and password.

#470995

Profile photo of pj
pj, January 27, 2013 at 11:41 am

I know that thangamalang, that is why I made a point of saying I have registered for several years, in the hopes people would realize I am not an idiot, just a slight blonde not a full blonde

#470996

Profile photo of James
thangamalang, January 27, 2013 at 11:56 am

I would never judge you, I just met you. I had to create a new username and password last year(2012). My old ones would not work from 2010 and before. If you did not register last year, you may have to create a new registration profile.

#470999

Profile photo of bsofranko
bsofranko, January 27, 2013 at 11:56 am

My guess is the site is overwhelmed with activity as I was able to log in recently but username not recognized today.. Will try again later!

#471000

Profile photo of Tom
trknight, January 27, 2013 at 12:24 pm

There must be some issues with the registration portal. I just tried to log in to check who else in my group had registered and my username was not recognized either (and I registered about a week ago). Could be a website problem….

#471006

Profile photo of James
Jboz, January 27, 2013 at 12:50 pm

Same issue. 2012 credentials were not recognized. Any downside to just starting over with a new sign on?

#471007

Profile photo of Dan in Iowa
Dan in Iowa, January 27, 2013 at 3:23 pm

I just couldn’t remember my sign in so I hit that button and they sent me new stuff. Same username as 2010 and I could set up a new password. Simple.

#471055

Profile photo of George
Bear59, January 27, 2013 at 3:30 pm

Having the same problem…says to login but username doesn’t come back as recognized/valid. I guess I’ll wait for a few hours.

#471057

Profile photo of Peggy
Peggy Kerr, January 27, 2013 at 3:33 pm

The Registration site is not working. Had the same problems when I just wanted to check into the status of our group and see how many had registered so far. Maybe it’s been swamped – this “shortest route ever” thing is going to be bringing people out of the woodwork.

#471058

Profile photo of Nancy
ThinkPie, January 27, 2013 at 4:29 pm

We are having the same issues. It won’t let me register under my old (last year and before) name and password, NOR will it let me register as a new rider. Ugh. I do hope its because the site is overwhelmed.

#471062

The forum ‘RAGBRAI XLI – 2013’ is closed to new topics and replies.

Categories

RAGBRAI XLV – 2017

RAGBRAI XLIV – 2016

RAGBRAI XLIII – 2015

RAGBRAI XLII – 2014

RAGBRAI XLI – 2013

Training

Clubs, Teams & Charters

Lost and Found

Miscellaneous

Gatherings & Meetings

RAGBRAI XL – 2012

RAGBRAI XXXIX – 2011

Members